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CHAPTER 1 FILLING DATA 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of filling 

 learn how to use Fill to create a series of values 

 learn how to use Fill to create a growth series 

 learn how to fill a series backwards from right to left 

 learn how to fill using the options on the SmartTag menu 

 learn how to create a custom fill list 

 learn how to modify a custom fill list 

 learn how to delete a custom fill list 

 learn how to use Flash Fill to extract text data 

 learn how to perform more complex extractions using 
Flash Fill 

 learn how to extract dates and values using Flash Fill. 

Filling refers to the process of filling cells with data. It is very much 
like copying the contents of one cell to another, and in some cases 
does exactly that. In other situations, filling can create a series of 
data items in consecutive cells. 

The fill handle and fill pointer are the tools used for filling. The fill 
handle is a black square that appears at the bottom right corner of 
the active cell. When you point to the fill handle with the mouse, the 
pointer changes to a thin, black cross known as the fill pointer. 

Filling is as simple as dragging the fill handle with the fill pointer. 

INFOCUS 
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UNDERSTANDING FILLING 
 

 

 

 

  

 

Excel enables you to quickly populate cells that 
follow a series, like fortnightly dates, months of 
the year, days of the week etc. This process is 
known as filling and requires you to indicate the 

first part of the series, before dragging the contents 
across or down to the other cells using the Fill 
handle. Below is a description of the different types 
of series that you can create using filling. 

The Fill Handle 

To create a series, you need to use the fill handle. This is the small black square located in the 
bottom right corner of a selected cell. By dragging the fill handle across or down to other adjacent 
cells, you fill these cells with a series. The AutoFill Options feature allows you to select what you 
want to fill.  

Types of Series 

A series refers to a sequence of ordered entries in adjacent cells, such as the days of the week or 
months of the year. 

When you fill to the right or down, you create a growth series where the values increment. Growth 
series require that you start with the first two values in the series so that Excel can determine the 
size of the increment to be used. For example, the values could be payroll dates two weeks apart. 
Excel would use that to determine that you want to increment the date value by 14 each time. If you 
use a combination of a label and a number, you can start a growth series with one value. For 
example, Day 1 would become Day 2, Day 3, and so on 

If you fill to the left or upwards, you will create a decrementing series, where the numbers decrease 
and the series will be filled in order down the values. 

You can also use the fill options to create a series. The options include normal copying, copying 
formats or values only, and creating a series of dates that only includes weekdays. To access the 
options, you click on the drop arrow of the AutoFill Options feature. The AutoFill Options feature 
appears after you complete a successful fill operation. 

Although most of Excel’s filling options come from pre-created, built-in lists, you can also create your 
own custom lists, for instance, department names or product categories. 

The fill handle 

The Auto Fill Options 
feature 
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FILLING A SERIES 
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A series refers to a sequence of ordered entries 
in adjacent cells, such as the days of the week or 
months of the year. The fill technique can be 
used to create these in a worksheet for you, 

reducing the amount of time taken for data entry 
and ensuring that the spelling is correct. Excel 
provides days and months as special built-in series 
that you can access. 

Try This Yourself: 
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Before starting this 
exercise you MUST open 
the file Filling 
Data_1.xlsx… 

 
Click in cell A3 to make 
this the active cell 

 
Point to the fill handle until 
the mouse pointer 
appears as a black cross 

 
Click and drag to cell F3  

Excel will fill the range 
with the first six months of 
the year… 

 
Click in cell A4 and repeat 
steps 2 and 3 to create a 
series of months with their 
full names 

You can also fill more than 
one row at a time… 

 
Select the range A5:A11 

 
Click on the fill handle and 
drag across to column F 

 
Examine each of the 
series created by the 
filling process 
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For Your Reference… 

To fill a series: 

1. Click in the first cell in the series 

2. Drag the fill handle across as many columns 
as required 

Handy to Know… 

 As you drag the fill handle across, a tool tip 
appears below the fill pointer displaying the 
current value in the series. This is useful 
when you want to end on a particular day, 
month or value. 
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FILLING A GROWTH SERIES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The fill handle can also be used to create growth 
series – where the values increment. Growth 
series require that you start with the first two 
values in the series so that Excel can determine 

the size of the increment to be used. For example, 
the values could be payroll dates two weeks apart. 
Excel would use that to determine that you want to 
increment the date value by 14 each time. 

Try This Yourself: 
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 Continue using the previous 

file with this exercise, or open 
the file Filling Data_2.xlsx... 

 
Scroll down and click in cell 
A14 to make it active 

 
Click and drag the fill handle 
across to cell F14 

Excel will copy 23 across the 
cells because it has no 
reason to think you wanted to 
change the value… 

 
Select the range A15:B15 

The values in these cells have 
a difference of 12… 

 
Click and drag the fill handle 
across to cell F15 

The values increase by 12… 

 
Repeat steps 3 and 4 for the 
range A16:B16 

The dates increase by 14… 

 
Ensure the range A16:F16 is 
selected, then, on the HOME 
tab, click on Format in the 
Cells group and click on 
Autofit Column Width 

 
Repeat steps 3 and 4 for the 
range A17:B17 

Excel can see a pattern for 
the first cell, but not the 
second, so it increments the 
Region cells only 
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For Your Reference… 

To fill a growth series: 

1. Select the first two values of the series 

2. Click and drag the fill handle across as many 
columns as required 

7 

Handy to Know… 

 If you use a combination of a label and a 
number, you can start a growth series with 
one value. For example, Day 1 would 
become Day 2, Day 3, and so on. 
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FILLING A SERIES BACKWARDS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When you fill to the right or down, the numbers 
increase or the series progresses forwards. If you 
fill to the left or upwards, the numbers will 
decrease and the series will be filled in order 

down the values. In other words, to create an 
incrementing series, you fill down or to the right. 
To create a decrementing series, you fill up or to 
the left – that is, you fill backwards. 

Try This Yourself: 
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previous file with this 
exercise, or open the 
file Filling 
Data_3.xlsx... 

 
Select the range 
G20:H20 

 
Click and drag the fill 
handle left to cell A20 

 
Click in cell H21 to 
make it active 

 
Click and drag the fill 
handle to cell A21 

The months will be 
filled backwards in 
their usual series order 

 

1 
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For Your Reference… 

To fill a series backwards: 

1. Select the last cell(s) in the series 

2. Drag the fill handle to the left or upwards 
until the desired starting point in the series is 
reached 

Handy to Know… 

 If you backwards fill a series that consists of 
a text label and number, you will find that the 
numbers do not become negative; they will 
reverse in order after reaching zero. 

 You can delete the contents of a single cell 
by dragging the fill handle upwards over the 
cell. 

4 

Sam
ple



Microsoft Excel 2016 - Level 2 

© Watsonia Publishing Page 6 Chapter 1 - Filling Data 

FILLING USING OPTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When you fill from a single date, Excel assumes 
that the increment level is by day. However, if 
you want to create a series that increments by 
month or year you can use the fill options. 

These options include normal copying, copying 
formats or values only, and creating a series of 
dates that only includes weekdays. To access the 
options, you click on the SmartTag drop arrow. 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
Filling Data_4.xlsx... 

 
Scroll to and click in cell 
A24, then drag the fill 
handle across to cell F24 

Excel automatically 
increments by day… 

 
Click on the drop arrow for 
the SmartTag to display a 
menu of options  

 
Select Fill Months 

The series adjusts to 
increments by months. The 
final value is now 
1/6/2010… 

 
Repeat steps 1 to 3 for cell 
A25, but this time select 
Fill Years 

Now the final value is 
1/01/2015. 

Let’s fill the format only… 

 
Click in cell A26 and drag 
the fill handle across to cell 
F26 

 
Click on the drop arrow for 
the SmartTag and select 
Fill Formatting Only 

The currency format will be 
copied to the other cells 
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For Your Reference… 

To use fill options: 

1. Click on the first cell of the series 

2. Fill using the fill handle 

3. Select the required option from the drop 
arrow for the SmartTag 
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Handy to Know… 

 The fill options can overcome the need to 
have two starting values in a sequence. For 
example, if you want to fill numbers with an 
increment of 5, fill from the first number using 
the right mouse button, select Series… from 
the shortcut menu, type a Step value of 5, 
then click on [OK]. 
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CREATING A CUSTOM FILL LIST 
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Most of Excel’s filling techniques come from pre-
created, built-in lists. For example, the names of 
the months are stored in a list that is accessed 
when you attempt to fill a range based on the 

name of one of those months that is in the list. You 
can also create your own custom lists to use for 
fill operations. 

2 
Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
Filling Data_5.xlsx... 

 
Click on the Custom 
Series worksheet tab 

 
Click in cell A5, hold down 

, then click in cell A11 

to select the range A5:A11 

 
Click on the File tab, then 
click on Options to display 
the Excel Options dialog 
box 

 
Click on Advanced in the 
list on the left, scroll to 
General and click on [Edit 
Custom Lists] to display 
the Custom Lists dialog 
box 

 
Click on [Import] to import 
the selected text into the 
Custom lists 

 
Click on [OK] to close each 
dialog box and return to the 
worksheet 

 
Click in cell C5, type 
Boardroom, then click and 
drag the fill handle down to 
cell C18 
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For Your Reference… 

To create a custom list: 

1. Type and select the list in the worksheet 

2. Click on the File tab, then click on Options 

3. Click on Advanced, then click on [Edit 
Custom Lists] 

4. Click on [Import], then click on [OK] 

Handy to Know… 

 You can create new custom lists in the 
Custom Lists dialog box by selecting New 
List in Custom lists, then click in List 
entries and type the entries in the required 
order. When you have completed the list, 

click on [Add]. 
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MODIFYING A CUSTOM FILL LIST 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can modify custom fill lists using the Custom 
Lists dialog box, which is accessed from the 
Excel Options dialog box. You can modify a list 
by displaying the list entries, making the required 

changes, then clicking on [Add] to update them. 
You cannot however modify the standard, built-in 
lists that Microsoft Excel provides. 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or 
open the file Filling 
Data_6.xlsx... 

 
Click on the File tab, then 
click on Options to display 
the Excel Options dialog 
box 

 
Click on Advanced in the list 
on the left, scroll to General, 
then click on [Edit Custom 
Lists] to display the Custom 
Lists dialog box 

 
Click on Boardroom, Cafe… 
in Custom lists to see the 
List entries for this series 

 
Double click on Club in List 
entries to select it and type 
Cinema 

 
Click on [Add] to update the 
list, then click on [OK] to 
close each dialog box 

 
Click in cell C5, then click 
and drag the fill handle down 
to cell C18 to update the list 
with the new item 

 

4 
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For Your Reference… 

To modify a custom fill list: 

1. Click on the File tab and click on Options 

2. Click on Advanced, then click on [Edit 
Custom Lists] 

3. Click on the list to be modified 

For Your Reference (cont’d)… 

4. Change the entries as required 

5. Click on [Add] 

6. Click on [OK] to close each dialog box 
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DELETING A CUSTOM FILL LIST 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Custom fill lists are available system-wide. This 
means that no matter which workbook you have 
open, everyone will be able to access and use 
your custom fill lists. As custom fill lists become 

out-dated or are no longer needed they can easily 

be deleted from the Custom Lists dialog box. 

Try This Yourself: 
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 Continue using the previous 

file with this exercise, or open 
the file Filling Data_7.xlsx... 

 
Click on the File tab, then 
click on Options to display 
the Excel Options dialog box 

 
Click on Advanced in the list 
on the left, scroll to General, 
then click on [Edit Custom 
Lists] to display the Custom 
Lists dialog box 

 
Click on Boardroom, Cafe… 
in Custom lists to see the 
List entries for this series 

 
Click on [Delete] to start the 
deletion process 

Excel will now warn you that 
the list will be permanently 
deleted from the system… 

 
Click on [OK] to delete the list 

 
Click on [OK] to close each 
dialog box and return to the 
workbook 
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For Your Reference… 

To delete a custom fill list: 

1. Click on the File tab, then click on Options 

2. Click on Advanced 

3. Click on [Edit Custom Lists] in General 

4. Click on the list to be modified 

For Your Reference (cont’d)… 

5. Click on [Delete] 

6. Click on [OK] to confirm the deletion 

7. Click on [OK] to close the dialog boxes 
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EXTRACTING WITH FLASH FILL 
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The normal fill operation is used to fill cells with 
either copied data or a series based on content in 
adjacent cells. Flash Fill will fill cells with pattern 
matches extracted from adjacent cells. These 

matches are based on an example that needs to be 
entered into the first fill cell. While normal fill looks 
for a pattern between cells, Flash Fill looks for 
patterns within one or more cells.  

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file Filling 
Data_8.xlsx… 

 
Click in cell B2, type Wilson, 

then press  +  

Pressing  +  enters 

data in the cell but keeps the 
cell active rather than moving 
down to the next cell… 

 
On the Home tab, click on Fill 
in the Editing group, then 
select on Flash Fill 

All of the last names of the 
members will now be extracted 
to column B… 

 
Type Roger, then press  +

 to update the list with first 

names 

 
Click in cell C2, type Wilson, 

then press  +   

 
Click on Fill in the Editing 
group, then click on Flash Fill 
to extract the last names 

 
Click in cell D2, type RW, then 
press  +   

 
Click on Fill in the Editing 
group, then click on Flash Fill 
to extract the initials of the 
members 

 

1 
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For Your Reference… 

To use Flash Fill: 

1. Type the data to extract in the cell to the right 
of the source data 

2. Click on the Home tab, then click on Fill in 
the Editing group and click on Flash Fill 

Handy to Know… 

 Sometimes Flash Fill fills upwards. You’ll 
notice in the example above that the heading 
Member and then the initial for this (M) 
appears above the fill data. You can delete 
these if they are not wanted. 
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MORE COMPLEX FLASH FILL EXTRACTIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Flash Fill can be a powerful fill tool for extracting 
data to adjacent cells. In addition to performing 
simple, single criteria extractions, you can also 
perform more complex extractions based on 

multiple criteria. Flash Fill also allows you to insert 
additional text and data into extractions allowing 
you to create merged sentences based on 
extracted and fixed text. 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
Filling Data_9.xlsx... 

 
Click on the Flash Fill 2 
worksheet tab 

 
Click in cell C2, type 
Brighton, then press  

+   

 
On the Home tab, click on 
Fill in the Editing group, 
then select Flash Fill 

All of the suburbs from the 
longer address cells will 
now be extracted to 
column C… 

 
Ensure that C2 is still the 
active cell, type 3186, 

then press  +  to 

display only the postal 
codes from the addresses 

 
Ensure that C2 is still the 
active cell, type Wilson, 
Roger lives in Brighton, 

then press  +  to 

display a sentence 

The sentence here is 
made up of extracted data 
(the last name, initial, and 
suburb) and also fixed 
text 
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For Your Reference… 

To perform complex extractions with Flash Fill: 

1. Type a sample of the data to extract in the 
cell to the right of the source data 

2. Click on the Home tab  

3. Click on Fill in the Editing group and click 
on Flash Fill 

Handy to Know… 

 The process of joining text together is 
referred to as concatenation in computer 
jargon. Concatenation can also be achieved 
by creating special formulas that string the 
contents of the cells together. 
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EXTRACTING DATES AND NUMBERS 
 

 

 

 

 

 

 

 

 

  

Flash Fill is a great tool for extracting text into 
adjacent cells. You can also insert additional 
fixed text to create complex sentences. Flash Fill 
will also work with dates and numbers. However, 

care needs to be taken here especially when 
numbers are also used in text cells such as 
addresses. 

Try This Yourself: 

S
a

m
e

 

F
il

e
 

Continue using the 
previous file with this 
exercise, or open the file 
Filling Data_10.xlsx... 

 
Click on the Flash Fill 3 
worksheet tab 

 
Click in cell D2, type Jan, 

then press  +   

 
On the Home tab, click on 
Fill in the Editing group, 
then select Flash Fill 

The names of the months 
will now be extracted into 
column D… 

 
Ensure that cell D2 is still 
active, type 36,455, then 
press  +  to 

display only the integer 
part of the savings 
amount 

 
Ensure that cell D2 is still 
active  

 
Type Wilson, R has 
saved 36,455.34 since 

1989, then press  + 

 to display a sentence 

that combines text, values 
and dates  
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For Your Reference… 

To extract dates and numbers with Flash Fill: 

1. Type a sample of the date or value to extract 
in the cell to the right of the source data 

2. Click on the Home tab 

3. Click on Fill in the Editing group and click 
on Flash Fill 
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Handy to Know… 

 Like all things to do with spreadsheets, you 
should carefully check results of operations 
such as copying and filling. 
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